neighbor update-source
Configures the router to force BGP to use the IP address of the loopback interface when talking to a neighbor.
Syntax: [no] neighbor {ip-address | peer-group-name} update-source loopback identifier
ip-address
IP address of the BGP neighbor.
peer-group-name
Name of a BGP peer group.
loopback identifier
Name of a loopback interface.
Description: Loopback interfaces enable you to allow your internal BGP connections to stay up no matter what interface is used to reach a neighbor. There are three steps to configure a router to support a loopback interface:
- Use the interface command to configure a loopback interface and assign it an IP address.
- Use the neighbor update-source command to configure the update source as the loopback interface.
- Configure your neighbors to use the address of a loopback interface.
Use the neighbor update-source command to force BGP to use the IP address of the specified loopback interface when talking to a neighbor.
Use the no neighbor update-source command to restore the interface assignment as the closest interface (best local address).
Factory Default: BGP TCP connection to neighbor is via best local address.
Command Mode: Router configuration.
Example 1: In the following example, this router (Router A) is configured with a loopback interface and a neighbor (Router B) is configured to use the loopback interface for connections to Router A:
Configuration for Router A:
- The interface command configures a loopback interface.
- The ip address command specifies the IP address of the loopback interface.
- The neighbor update-source command specifies that BGP connections to the neighbor are sourced from the loopback interface's IP address.
router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
router(config)#interface loopback 25
router(config-if)#ip address 160.69.2.4 255.255.0.0
router(config-if)#end
router(config)#router bgp 101
router(config-router)#network 160.69.0.0
router(config-router)#neighbor 160.69.2.3 remote-as 101
router(config-router)#neighbor 160.69.2.3 update-source Loopback 25
Configuration for Router B:
- The neighbor remote-as command specifies that Router B uses the loopback interface for connections to router A.
router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
router(config)#router bgp 101
router(config-router)#neighbor 160.69.2.4 remote-as 101
Example 2: The following example restores the interface assignment to the best local address:
router(config-router)#no neighbor 160.69.2.3 update-source Loopback 25
Related Commands: neighbor peer-group
neighbor remote-as
interface
show interfaces loopback
ip address
Copyright © 2004
Avici Systems Inc.
Avici® and TSR®
is a registered trademark of Avici Systems Inc.
IPriori, Composite Links, SSR, QSR, and NSR® are
trademarks of Avici Systems Inc.
Source
File Name: BGP_Nd.fm
HTML File Name: BGP_Nd45.html
Last Updated: 05/10/04 at 16:36:55